[Kolab-devel] Kolab 2 build gets "Could not bind to LDAP server: Invalid credentials" on admin screen

Peter Berry pberry at uk2.net
Wed Aug 25 23:00:13 CEST 2004


I downloaded all the sources for Kolab 2 and ran obmtool. The install goes
through fine.

I then executed /kolab/etc/kolab/kolab_bootstrap and answered all the
questions appropriately.

Initially I then fired up Kolab with /kolab/bin/openpkg rc all start. But
then I worked out that the configuration hadn't pushed through so I
executed /kolab/sbin/kolabconf and tried again and apache is now setup

Interesting aside openldap fails to start at this point complaining that
/kolab/etc/openldap/slapd.replicas doesn't exist, so I checked the
template which seems to be empty(apart from some comments) so I just
copied it over into the correct location manually.

Finally everything fires up so I go to the admin page and get the
following error on the page:
"Could not bind to LDAP server: Invalid credentials"

So I tracked through the PHP code to find the error. It seems to die at:
    // Anon. bind first
    if( !$ldap->bind( $_SESSION['php_dn'],  $_SESSION['php_pw'] ) ) {
      $this->error_string = _("Could not bind to LDAP server:
in auth.class.php which is just the anonymous login.

I am assuming that I haven't missed any setup steps for Kolab 2 - I pretty
much did similiar steps as those I did for version 1.



More information about the devel mailing list