[Kolab-devel] Installation fails on ubuntu 12.0.4, report

Timotheus Pokorra timotheus at pokorra.de
Fri Nov 8 09:45:49 CET 2013

Hello Alexander,
in the IRC, Jeroen wrote:
> someone needs to create a package for python-ldap and correct the packaging nonsense in the apache mpm

I have done the first step, see https://obs.kolabsys.com/request/show/195
So now there is an uptodate package (>= 2.4~) for python-ldap
available for Ubuntu 12.04 and 12.10 in the Development repository.

Side note to the list:
there is this problem sometimes on OBS when building packages for Ubuntu:

[  409s] [199/204] installing initscripts
[  409s] Selecting previously unselected package initscripts.
[  411s] guest environment detected: Linking /run/shm to /dev/shm
[  411s] rmdir: failed to remove `/run/shm': Device or resource busy
[  411s] Can't symlink /run/shm to /dev/shm; please fix manually.
[  411s] dpkg: error processing initscripts (--install):
[  411s]  subprocess installed post-installation script returned error
exit status 1
[  411s] Processing triggers for man-db ...
[  412s] Errors were encountered while processing:
[  412s]  initscripts
[  412s] exit ...

Retriggering the build usually helps.
Any idea if this could be fixed somehow?


On 7 November 2013 11:48, Alexander Reichstadt
<areichstadt at googlemail.com> wrote:
> Hi,
> as per request I'd like to report a problem.
> I am running Ubuntu 12.0.4, updated and upgraded properly and vanilla
> install. To test kolab I run this on a virtual machine with fixed IP, doing
> some research to replace an SBS 2003's mailserver. That's how I came to test
> kolab.
> I tried thew following instructions:
> <http://docs.kolab.org/installation-guide/ubuntu.html>
> On the next page of this guideline it says to enter setup-kolab.
> The result is command not found.
> As it turned out, actually nothing was installed, I verified it like so:
> find / -name "*kolab*"
> /var/lib/apt/lists/obs.kolabsys.com:82_Kolab:_3.1:_Updates_Ubuntu%5f12.04_._Release
> /var/lib/apt/lists/obs.kolabsys.com:82_Kolab:_3.1:_Updates_Ubuntu%5f12.04_._Packages
> /var/lib/apt/lists/obs.kolabsys.com:82_Kolab:_3.1:_Updates_Ubuntu%5f12.04_._Release.gpg
> /var/lib/apt/lists/obs.kolabsys.com:82_Kolab:_3.1_Ubuntu%5f12.04_._Packages
> /var/lib/apt/lists/obs.kolabsys.com:82_Kolab:_3.1_Ubuntu%5f12.04_._Release
> /var/lib/apt/lists/obs.kolabsys.com:82_Kolab:_3.1_Ubuntu%5f12.04_._Release.gpg
> /etc/apt/preferences.d/kolab
> root at mail:~# setup-kolab
> I posted an full output of the installation attempt from scratch here:
> http://tny.cz/71ac84d0
> So, in the IRC channel I got help and told to contact he mailing list.
> I am happy to test and log bugs, I have no experience in packaging for
> ubuntu or the like.
> Any ideas how to go about resolving this issue?
> Regards
> kolabtester
> _______________________________________________
> devel mailing list
> devel at lists.kolab.org
> https://lists.kolab.org/mailman/listinfo/devel

More information about the devel mailing list