[Kolab-devel] Installation fails on ubuntu 12.0.4, report

Timotheus Pokorra timotheus at pokorra.de
Fri Nov 8 10:28:02 CET 2013

I briefly looked into the apache mpm dependancy problems.

I found this mail explaining the core problem:

apt-get install -f libapache2-mod-php5
apt-get install kolab

but now there are more dependany errors.

aptitude install kolab php-kolab smarty3 php-net-ldap2 libmozldap-0d
still gives these errors:
The following packages have unmet dependencies:
 roundcubemail-plugins-kolab : Depends: php-http-request2 which is a
virtual package.
                               Depends: php-net-url2 which is a virtual package.
 kolab-webadmin : Depends: smarty3 (>= 3.1.7) but 3.0.8-1fakesync1 is
to be installed.

there is a package in Ubuntu 14.04 (trusty tahr):
no package php-net-url2 for Ubuntu 12.04 (precise)
smarty3 is too old.

I have to stop now, need to do some other work...


On 8 November 2013 09:45, Timotheus Pokorra <timotheus at pokorra.de> wrote:
> Hello Alexander,
> in the IRC, Jeroen wrote:
>> someone needs to create a package for python-ldap and correct the packaging nonsense in the apache mpm
> I have done the first step, see https://obs.kolabsys.com/request/show/195
> So now there is an uptodate package (>= 2.4~) for python-ldap
> available for Ubuntu 12.04 and 12.10 in the Development repository.

More information about the devel mailing list