Installation: webadmin broken, missing session_vars.php

Jan Gerle jan.gerle at
Sun Sep 3 19:16:03 CEST 2006

Hi list

After several installation attempts on a Debian 3.1 box and a day of
googling it seems to me that the debian installation packages from are missing at least one file (session_vars.php) and are not
properly completing webserver configuration.

What did I do? At first I downloaded all RPM packages from
(also tried 2.0.3, 2.1beta2), then proceeded just like advised in the
1st.README. Installation went just fine, created some SSL certificates,
finally I got kindly asked to visit https://$myhost.$tld/admin/.

Guess what? Right, went there, got "Connection refused". After a some
quick checks it showed up that the apache webserver only listened on Investigating /kolab/etc/apache/apache.conf it seemed to
me that the whole file looked somewhat... unconfigured, including a
hostname like purple1.rgb :-/ I changed the appropiate VirtualHost stuff
and restarted the webserver (/kolab/bin/openpkg rc apache stop/start).

Now I finally could connect to the webserver, only to be presented the
apache-ssl default page, no /admin/ available. A few minutes/hours later
I found the location of the admin interface (/kolab/var/kolab/www and
/kolab/var/kolab/php), reconfigured apache, restarted - tadaaa! Blank
screen, how annoying :-/ A quick peek into the apache error.log revealed
the missing session_vars.php which I could not find in any RPM package.

I'm stuck! What is this?! Please help, I am neither dumb nor lazy but I
am growing more and more tired...

BIG thanks in advance for any help,

P.S.: Did I tell you about the kolab proftp which I just cannot
stop/kill? Maybe another time, my server box is rebooting to get rid of
the process...
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 3607 bytes
Desc: S/MIME Cryptographic Signature
URL: <>

More information about the users mailing list