Installation auf Fedora 20

Yunus Koc widdersoft at outlook.de
Sa Jul 5 21:17:35 CEST 2014


Guten Tag liebe Community, 

ich bin während meiner Recherche über Groupwares auf Kolab gestoßen und wollte es auf Fedora 20 installieren. Doch leider geht es nicht. Ich erhalte folgende Fehlermeldungen (Bedeuten die Meldungen, dass ich die Pakete zu neu sind?):
Beim Beispiel Python, wie finde ich Python 2.6, wenn die niedrigste Versionierung 2.6 ist? Ist aus Sicherheitsgründen nicht gefählrich, eine niedrigere Versionnierung zu benutzen?
Wenn ich die alten Versionierungen finden und installieren will, wie finde ich diese?

Nach der Recherche im Planet Kolab und dem Wiki sowie der Dokumentation bin ich auf eine Anleitung gekommen, wie ich es unter CentOS installieren kann mit Owncloud integration. Auch wenn CentOS zu RHEL gehört genau so wie Fedora, würde ich dennoch Fedora (oder sogar Korora als Spin) benutzen wollen.

Lieben Gruß

Error: Package: php-kolabformat-1.0.1-8.3.el6.kolab_3.2.x86_64 (Kolab_3.2_Updates)
           Requires: php(api) = 20090626
           Installed: php-common-5.5.14-1.fc20.remi.x86_64 (@remi)
               php(api) = 20121113-64
           Available: php-common-5.5.6-1.fc20.i686 (fedora)
               php(api) = 20121113-32
           Available: php-common-5.5.14-1.fc20.i686 (updates)
               php(api) = 20121113-32
Error: Package: kolab-server-0.6.13-10.13.el6.kolab_3.2.noarch (Kolab_3.2_Updates)
           Requires: python(abi) = 2.6
           Installed: python-2.7.5-13.fc20.x86_64 (@updates)
               python(abi) = 2.7
               python(abi) = 2.7
           Installed: python3-3.3.2-17.fc20.x86_64 (@updates)
               python(abi) = 3.3
           Available: python-2.7.5-9.fc20.i686 (fedora)
               python(abi) = 2.7
               python(abi) = 2.7
           Available: python3-3.3.2-8.fc20.i686 (fedora)
               python(abi) = 3.3
Error: Package: pykolab-xml-0.6.13-10.13.el6.kolab_3.2.noarch (Kolab_3.2_Updates)
           Requires: python(abi) = 2.6
           Installed: python-2.7.5-13.fc20.x86_64 (@updates)
               python(abi) = 2.7
               python(abi) = 2.7
           Installed: python3-3.3.2-17.fc20.x86_64 (@updates)
               python(abi) = 3.3
           Available: python-2.7.5-9.fc20.i686 (fedora)
               python(abi) = 2.7
               python(abi) = 2.7
           Available: python3-3.3.2-8.fc20.i686 (fedora)
               python(abi) = 3.3
Error: Package: libkolab-0.5.0-7.1.el6.kolab_3.2.x86_64 (Kolab_3.2)
           Requires: libboost_system-mt.so.5()(64bit)
Error: Package: php-kolab-0.5.0-7.1.el6.kolab_3.2.x86_64 (Kolab_3.2)
           Requires: php(api) = 20090626
           Installed: php-common-5.5.14-1.fc20.remi.x86_64 (@remi)
               php(api) = 20121113-64
           Available: php-common-5.5.6-1.fc20.i686 (fedora)
               php(api) = 20121113-32
           Available: php-common-5.5.14-1.fc20.i686 (updates)
               php(api) = 20121113-32
Error: Package: kolab-utils-3.0.5-11.1.el6.kolab_3.2.x86_64 (Kolab_3.2)
           Requires: libxerces-c-3.0.so()(64bit)
Error: Package: php-kolab-0.5.0-7.1.el6.kolab_3.2.x86_64 (Kolab_3.2)
           Requires: php(zend-abi) = 20090626
           Installed: php-common-5.5.14-1.fc20.remi.x86_64 (@remi)
               php(zend-abi) = 20121212-64
           Available: php-common-5.5.6-1.fc20.i686 (fedora)
               php(zend-abi) = 20121212-32
           Available: php-common-5.5.14-1.fc20.i686 (updates)
               php(zend-abi) = 20121212-32
Error: Package: php-gd-5.5.14-1.fc20.x86_64 (updates)
           Requires: php-common(x86-64) = 5.5.14-1.fc20
           Installed: php-common-5.5.14-1.fc20.remi.x86_64 (@remi)
               php-common(x86-64) = 5.5.14-1.fc20.remi
           Available: php-common-5.5.6-1.fc20.x86_64 (fedora)
               php-common(x86-64) = 5.5.6-1.fc20
           Available: php-common-5.5.14-1.fc20.x86_64 (updates)
               php-common(x86-64) = 5.5.14-1.fc20
Error: Package: libcalendaring-4.9.0-16.1.el6.kolab_3.2.x86_64 (Kolab_3.2)
           Requires: libsasl2.so.2()(64bit)
Error: Package: libkolab-0.5.0-7.1.el6.kolab_3.2.x86_64 (Kolab_3.2)
           Requires: libboost_thread-mt.so.5()(64bit)
Error: Package: libkolabxml-1.0.1-8.3.el6.kolab_3.2.x86_64 (Kolab_3.2_Updates)
           Requires: libxerces-c-3.0.so()(64bit)
Error: Package: python-ldap-2.4.6-12.1.el6.kolab_3.2.x86_64 (Kolab_3.2)
           Requires: libpython2.6.so.1.0()(64bit)
Error: Package: libkolabxml-1.0.1-8.3.el6.kolab_3.2.x86_64 (Kolab_3.2_Updates)
           Requires: libboost_thread-mt.so.5()(64bit)
Error: Package: cyrus-imapd-2.5-2.8.el6.kolab_3.2.x86_64 (Kolab_3.2_Updates)
           Requires: libnetsnmpagent.so.20()(64bit)
Error: Package: cyrus-imapd-2.5-2.8.el6.kolab_3.2.x86_64 (Kolab_3.2_Updates)
           Requires: libnetsnmpmibs.so.20()(64bit)
Error: Package: cyrus-imapd-2.5-2.8.el6.kolab_3.2.x86_64 (Kolab_3.2_Updates)
           Requires: libnetsnmp.so.20()(64bit)
Error: Package: mozldap-6.0.5-28.3.el6.kolab_3.2.x86_64 (Kolab_3.2_Updates)
           Requires: libsasl2.so.2()(64bit)
Error: Package: python-kolabformat-1.0.1-8.3.el6.kolab_3.2.x86_64 (Kolab_3.2_Updates)
           Requires: python(abi) = 2.6
           Installed: python-2.7.5-13.fc20.x86_64 (@updates)
               python(abi) = 2.7
               python(abi) = 2.7
           Installed: python3-3.3.2-17.fc20.x86_64 (@updates)
               python(abi) = 3.3
           Available: python-2.7.5-9.fc20.i686 (fedora)
               python(abi) = 2.7
               python(abi) = 2.7
           Available: python3-3.3.2-8.fc20.i686 (fedora)
               python(abi) = 3.3
Error: Package: kolab-utils-3.0.5-11.1.el6.kolab_3.2.x86_64 (Kolab_3.2)
           Requires: libboost_system-mt.so.5()(64bit)
Error: Package: php-kolabformat-1.0.1-8.3.el6.kolab_3.2.x86_64 (Kolab_3.2_Updates)
           Requires: libboost_thread-mt.so.5()(64bit)
Error: Package: php-kolabformat-1.0.1-8.3.el6.kolab_3.2.x86_64 (Kolab_3.2_Updates)
           Requires: php(zend-abi) = 20090626
           Installed: php-common-5.5.14-1.fc20.remi.x86_64 (@remi)
               php(zend-abi) = 20121212-64
           Available: php-common-5.5.6-1.fc20.i686 (fedora)
               php(zend-abi) = 20121212-32
           Available: php-common-5.5.14-1.fc20.i686 (updates)
               php(zend-abi) = 20121212-32
Error: Package: cyrus-imapd-2.5-2.8.el6.kolab_3.2.x86_64 (Kolab_3.2_Updates)
           Requires: libdb-4.7.so()(64bit)
Error: Package: libcalendaring-4.9.0-16.1.el6.kolab_3.2.x86_64 (Kolab_3.2)
           Requires: libicalss.so.0()(64bit)
Error: Package: php-kolab-0.5.0-7.1.el6.kolab_3.2.x86_64 (Kolab_3.2)
           Requires: libboost_system-mt.so.5()(64bit)
Error: Package: python-kolabformat-1.0.1-8.3.el6.kolab_3.2.x86_64 (Kolab_3.2_Updates)
           Requires: libboost_system-mt.so.5()(64bit)
Error: Package: python-icalendar-3.4-12.1.el6.kolab_3.2.noarch (Kolab_3.2)
           Requires: python(abi) = 2.6
           Installed: python-2.7.5-13.fc20.x86_64 (@updates)
               python(abi) = 2.7
               python(abi) = 2.7
           Installed: python3-3.3.2-17.fc20.x86_64 (@updates)
               python(abi) = 3.3
           Available: python-2.7.5-9.fc20.i686 (fedora)
               python(abi) = 2.7
               python(abi) = 2.7
           Available: python3-3.3.2-8.fc20.i686 (fedora)
               python(abi) = 3.3
Error: Package: kolab-utils-3.0.5-11.1.el6.kolab_3.2.x86_64 (Kolab_3.2)
           Requires: libboost_thread-mt.so.5()(64bit)
Error: Package: php-kolabformat-1.0.1-8.3.el6.kolab_3.2.x86_64 (Kolab_3.2_Updates)
           Requires: libboost_system-mt.so.5()(64bit)
Error: Package: php-bcmath-5.5.14-1.fc20.x86_64 (updates)
           Requires: php-common(x86-64) = 5.5.14-1.fc20
           Installed: php-common-5.5.14-1.fc20.remi.x86_64 (@remi)
               php-common(x86-64) = 5.5.14-1.fc20.remi
           Available: php-common-5.5.6-1.fc20.x86_64 (fedora)
               php-common(x86-64) = 5.5.6-1.fc20
           Available: php-common-5.5.14-1.fc20.x86_64 (updates)
               php-common(x86-64) = 5.5.14-1.fc20
Error: Package: cyrus-imapd-2.5-2.8.el6.kolab_3.2.x86_64 (Kolab_3.2_Updates)
           Requires: libnetsnmphelpers.so.20()(64bit)
Error: Package: python-ldap-2.4.6-12.1.el6.kolab_3.2.x86_64 (Kolab_3.2)
           Requires: python(abi) = 2.6
           Installed: python-2.7.5-13.fc20.x86_64 (@updates)
               python(abi) = 2.7
               python(abi) = 2.7
           Installed: python3-3.3.2-17.fc20.x86_64 (@updates)
               python(abi) = 3.3
           Available: python-2.7.5-9.fc20.i686 (fedora)
               python(abi) = 2.7
               python(abi) = 2.7
           Available: python3-3.3.2-8.fc20.i686 (fedora)
               python(abi) = 3.3
Error: Package: python-kolabformat-1.0.1-8.3.el6.kolab_3.2.x86_64 (Kolab_3.2_Updates)
           Requires: libpython2.6.so.1.0()(64bit)
Error: Package: cyrus-imapd-2.5-2.8.el6.kolab_3.2.x86_64 (Kolab_3.2_Updates)
           Requires: perl(:MODULE_COMPAT_5.10.1)
Error: Package: cyrus-imapd-2.5-2.8.el6.kolab_3.2.x86_64 (Kolab_3.2_Updates)
           Requires: libsasl2.so.2()(64bit)
Error: Package: kolab-saslauthd-0.6.13-10.13.el6.kolab_3.2.noarch (Kolab_3.2_Updates)
           Requires: python(abi) = 2.6
           Installed: python-2.7.5-13.fc20.x86_64 (@updates)
               python(abi) = 2.7
               python(abi) = 2.7
           Installed: python3-3.3.2-17.fc20.x86_64 (@updates)
               python(abi) = 3.3
           Available: python-2.7.5-9.fc20.i686 (fedora)
               python(abi) = 2.7
               python(abi) = 2.7
           Available: python3-3.3.2-8.fc20.i686 (fedora)
               python(abi) = 3.3
Error: Package: libcalendaring-4.9.0-16.1.el6.kolab_3.2.x86_64 (Kolab_3.2)
           Requires: libical.so.0()(64bit)
Error: Package: python-kolabformat-1.0.1-8.3.el6.kolab_3.2.x86_64 (Kolab_3.2_Updates)
           Requires: libxerces-c-3.0.so()(64bit)
Error: Package: kolab-cli-0.6.13-10.13.el6.kolab_3.2.noarch (Kolab_3.2_Updates)
           Requires: python(abi) = 2.6
           Installed: python-2.7.5-13.fc20.x86_64 (@updates)
               python(abi) = 2.7
               python(abi) = 2.7
           Installed: python3-3.3.2-17.fc20.x86_64 (@updates)
               python(abi) = 3.3
           Available: python-2.7.5-9.fc20.i686 (fedora)
               python(abi) = 2.7
               python(abi) = 2.7
           Available: python3-3.3.2-8.fc20.i686 (fedora)
               python(abi) = 3.3
Error: Package: python-kolabformat-1.0.1-8.3.el6.kolab_3.2.x86_64 (Kolab_3.2_Updates)
           Requires: libboost_thread-mt.so.5()(64bit)
Error: Package: php-kolab-0.5.0-7.1.el6.kolab_3.2.x86_64 (Kolab_3.2)
           Requires: libboost_thread-mt.so.5()(64bit)
Error: Package: pykolab-0.6.13-10.13.el6.kolab_3.2.noarch (Kolab_3.2_Updates)
           Requires: python(abi) = 2.6
           Installed: python-2.7.5-13.fc20.x86_64 (@updates)
               python(abi) = 2.7
               python(abi) = 2.7
           Installed: python3-3.3.2-17.fc20.x86_64 (@updates)
               python(abi) = 3.3
           Available: python-2.7.5-9.fc20.i686 (fedora)
               python(abi) = 2.7
               python(abi) = 2.7
           Available: python3-3.3.2-8.fc20.i686 (fedora)
               python(abi) = 3.3
Error: Package: php-mbstring-5.5.14-1.fc20.x86_64 (updates)
           Requires: php-common(x86-64) = 5.5.14-1.fc20
           Installed: php-common-5.5.14-1.fc20.remi.x86_64 (@remi)
               php-common(x86-64) = 5.5.14-1.fc20.remi
           Available: php-common-5.5.6-1.fc20.x86_64 (fedora)
               php-common(x86-64) = 5.5.6-1.fc20
           Available: php-common-5.5.14-1.fc20.x86_64 (updates)
               php-common(x86-64) = 5.5.14-1.fc20
Error: Package: wallace-0.6.13-10.13.el6.kolab_3.2.noarch (Kolab_3.2_Updates)
           Requires: python(abi) = 2.6
           Installed: python-2.7.5-13.fc20.x86_64 (@updates)
               python(abi) = 2.7
               python(abi) = 2.7
           Installed: python3-3.3.2-17.fc20.x86_64 (@updates)
               python(abi) = 3.3
           Available: python-2.7.5-9.fc20.i686 (fedora)
               python(abi) = 2.7
               python(abi) = 2.7
           Available: python3-3.3.2-8.fc20.i686 (fedora)
               python(abi) = 3.3
Error: Package: 1:kdepim-runtime-4.12.5-1.fc20.x86_64 (@updates)
           Requires: libkolabxml.so.0()(64bit)
           Removing: libkolabxml-0.8.4-3.fc20.x86_64 (@fedora)
               libkolabxml.so.0()(64bit)
           Updated By: libkolabxml-1.0.1-8.3.el6.kolab_3.2.x86_64 (Kolab_3.2_Updates)
              ~libkolabxml.so.1()(64bit)
Error: Package: mozldap-tools-6.0.5-28.3.el6.kolab_3.2.x86_64 (Kolab_3.2_Updates)
           Requires: libsasl2.so.2()(64bit)
Error: Package: php-kolabformat-1.0.1-8.3.el6.kolab_3.2.x86_64 (Kolab_3.2_Updates)
           Requires: libxerces-c-3.0.so()(64bit)
Error: Package: php-mcrypt-5.5.14-1.fc20.x86_64 (updates)
           Requires: php-common(x86-64) = 5.5.14-1.fc20
           Installed: php-common-5.5.14-1.fc20.remi.x86_64 (@remi)
               php-common(x86-64) = 5.5.14-1.fc20.remi
           Available: php-common-5.5.6-1.fc20.x86_64 (fedora)
               php-common(x86-64) = 5.5.6-1.fc20
           Available: php-common-5.5.14-1.fc20.x86_64 (updates)
               php-common(x86-64) = 5.5.14-1.fc20
Error: Package: php-ldap-5.5.14-1.fc20.x86_64 (updates)
           Requires: php-common(x86-64) = 5.5.14-1.fc20
           Installed: php-common-5.5.14-1.fc20.remi.x86_64 (@remi)
               php-common(x86-64) = 5.5.14-1.fc20.remi
           Available: php-common-5.5.6-1.fc20.x86_64 (fedora)
               php-common(x86-64) = 5.5.6-1.fc20
           Available: php-common-5.5.14-1.fc20.x86_64 (updates)
               php-common(x86-64) = 5.5.14-1.fc20
Error: Package: libkolab-0.5.0-7.1.el6.kolab_3.2.x86_64 (Kolab_3.2)
           Requires: libxerces-c-3.0.so()(64bit)
Error: Package: libkolabxml-1.0.1-8.3.el6.kolab_3.2.x86_64 (Kolab_3.2_Updates)
           Requires: libboost_system-mt.so.5()(64bit)
Error: Package: php-pdo-5.5.14-1.fc20.x86_64 (updates)
           Requires: php-common(x86-64) = 5.5.14-1.fc20
           Installed: php-common-5.5.14-1.fc20.remi.x86_64 (@remi)
               php-common(x86-64) = 5.5.14-1.fc20.remi
           Available: php-common-5.5.6-1.fc20.x86_64 (fedora)
               php-common(x86-64) = 5.5.6-1.fc20
           Available: php-common-5.5.14-1.fc20.x86_64 (updates)
               php-common(x86-64) = 5.5.14-1.fc20
Error: Package: php-kolab-0.5.0-7.1.el6.kolab_3.2.x86_64 (Kolab_3.2)
           Requires: libxerces-c-3.0.so()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root at server yum.repos.d]# yum update
Loaded plugins: langpacks, priorities, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package libkolab.x86_64 0:0.4.2-3.fc20 will be updated
---> Package libkolab.x86_64 0:0.5.0-7.1.el6.kolab_3.2 will be an update
--> Processing Dependency: libcalendaring-kpimutils.so.0()(64bit) for package: libkolab-0.5.0-7.1.el6.kolab_3.2.x86_64
--> Processing Dependency: libcalendaring-akonadi-notes.so.0()(64bit) for package: libkolab-0.5.0-7.1.el6.kolab_3.2.x86_64
--> Processing Dependency: libboost_system-mt.so.5()(64bit) for package: libkolab-0.5.0-7.1.el6.