[Kolab-devel] Upgrade problem Kolab 2.2.0 -> 2.2.2

ITSEF Admin itsef-admin at brightsight.com
Tue Sep 22 17:52:46 CEST 2009

Hi *!

We're just in the process of testing an upgrade of our Debian 4.0/Kolab 2.2.0 
server to Debian 5.0/Kolab 2.2.2. We are using a separate test machine with 
an exact copy of the actual installation for this, so we can experiment a 

The most logical approach seemed to be to upgrade the OS first (Debian 4.0 -> 
5.0), then upgrade Kolab itself.

The OS upgrade went fine, the Kolab installation (based on the Debian 4.0 
OpenPKG RPMs provided by you) was still working. Hence, we went ahead and 
upgraded the Kolab installation using the Debian 5.0 OpenPKG RPMs (all x86).

On first try, the "install-kolab.sh" command failed with an error about a 
missing "openpkg install script". Apparently, this was caused by the change 
from Debian 4.0 to 5.0, which caused a mismatch in RPM names. The problem was 
solved by running
"sh openpkg-20071227-20071227_kolab1.ix86-debian5.0-kolab.sh" manually once, 
followed by the standard "install-kolab.sh" run.

According to the upgrade log, the upgrade seemingly went fine. The only thing 
we noticed was a large number of config files that were moved to ".rpmorig" - 
contrary to earlier upgrades, where we only encountered ".rpmsave" files. 
Also, the kolab.conf file was not touched.

Subsequently, we tried to follow the upgrade instructions with regard to LDAP. 
Using slapcat to export the ldif file and manipulating it with the awk script 
went fine. However, importing the result back into openldap with slapadd 
(after removing the existing DB, of course) failed:

/kolab/sbin/slapadd < test2.ldif
bdb_db_open: Warning - No DB_CONFIG file found in 
directory /kolab/var/openldap/openldap-data: (2)
Expect poor performance for suffix dc=my-domain,dc=com.
str2entry: invalid value for attributeType objectClass #1 (syntax
slapadd: could not parse entry (line=12)

As the "dc=my-domain,dc=com" seemed odd, we poked around a bit and found that 
the old slapd.conf had also been moved to "slapd.conf.rpmorig" - and the new 
one did not contain any configuration specific to our machine set-up. Also, 
it seemed to lack a few includes with regard to schemes.

We then tried replacing slapd.conf with the old version and - lo and behold - 
slapadd now worked without error.

Given that none of this is mentioned in the upgrade instructions, we are now a 
bit wary that something might have gone wrong during the upgrade - and hence 
wary to use the same procedure in the actual upgrade of the production 
server. Hence the question: Anybody out there who might have an idea as to 
what happened here and whether something actually went wrong or whether it's 
just something missing from the upgrade instructions?

As always, any enlightenment is most appreciated!


           Thomas Ribbrock, IT-Team brightsight

More information about the devel mailing list