[Kolab-devel] [xsd-users] Bug: failure to convert string to int

Till Adam adam at kde.org
Sat Feb 9 23:35:12 CET 2013


just to follow up on this:

On Jan 28, 2013, at 3:03 PM, Till Adam wrote:

> thanks for checking out the bug.
> On Jan 28, 2013, at 2:34 PM, Boris Kolpackov wrote:
>> Till Adam <adam at kde.org> writes:
>>> I seem to have stumbled upon a rather low level bug in libxsd on OSX Lion.
>> I tried to reproduce the bug on 10.8 and 10.3 (I don't have access to
>> 10.7) without any success. I tried 32/64, g++/clang++, optimized/non-
>> optimized combinations and they all seem to work fine.
> Weird, but encouraging, at least as far as 10.8 is concerned. I'll see if I can test on that.
>> It is also not clear what happens when the test fails. Does it crash?
>> Does it print a wrong value? If it crashes, would you be able to get
>> the stack trace?
> No, it does not crash, it simply prints 0, for the value of year. It seems to magically find an empty buffer, from what I can tell.
> I'll see if I can get more information. If someone else could confirm that it fails for them on 10.7, I would be grateful.

Frank and I did a bit more research and found by trial error that the bug only manifests with a certain version of Xcode (the one for Mountain Lion), only on Lion, only with g++. There was an Xcode update a few days ago, for Lion, which seems to resolve the issue provided one uses clang. So hopefully I just hit a bad time window, with a broken combination of OS/STL/compiler. That said, there are a bunch of bugs in this area on OSX, most can be mitigated by using deployment targets <=10.5, undefining _GLIBCXX_DEBUG or using clang, rather than c++. Just thought I'd post this result here, for documentation's sake, there does not seem to be anything xsd can or should do to help with these issues (other than building out of the box with clang, there's a still a tiny patch needed, but that's a known issue, I believe.

Thanks again,


More information about the devel mailing list