[Kolab-devel] [issue2562] Openpkg grep not compiling (possible lib64 issue)

Juan Carlos Ferrer kolab-issues at intevation.de
Tue Mar 25 19:21:59 CET 2008

New submission from Juan Carlos Ferrer <juan.ferrer at gmail.com>:

Grep does not want to compile, but if I run ./configure, make, make install in
the /kolab/RPM/TMP/grep-2.5.3 directory, it works fine.

install-kolab.sh runs this:
/kolab/bin/cc -DLIBDIR=\"/kolab/lib\"...

which later on gives errors such as:
/usr/include/gentoo-multilib/amd64/sys/cdefs.h:334:1: warning: this is the
location of the previous definition
grep.c: In function 'print_filename':
grep.c:689: warning: incompatible implicit declaration of built-in function 'printf'
grep.c:690: error: 'stdout' undeclared (first use in this function)

Where as if i run ./configure --infodir=/kolab/info... make and make install, it
used my system's gcc (and libs too i guess) instead of /kolab/bin/cc, and there
are no compilation errors.

Here is a diff between kolab-install.log and the output when I do it myself.

messages: 14187
nosy: juancferrer, thl, thomas
priority: bug
status: unread
title: Openpkg grep not compiling (possible lib64 issue)
Kolab issue tracker <kolab-issues at intevation.de>

More information about the devel mailing list