[Kolab-devel] Server 2.1.0 -> 2.2rc3 1st.README / update instructions

Bernhard Reiter bernhard at intevation.de
Sun Jun 22 13:23:23 CEST 2008

upgrading from server 2.1.0 to 2.2rc3 run smoothly.
Here are some notes about what caught my eye
and might be improved in the 1st.README or elsewhere.

(And I thought I cc kolab-devel@, maybe my comments help 
somebody else.)


Managing Director - Owner: www.intevation.net      (Free Software Company)
Germany Coordinator: fsfeurope.org. Coordinator: www.Kolab-Konsortium.com.
Intevation GmbH, Osnabrück, DE; Amtsgericht Osnabrück, HRB 18998
Geschäftsführer Frank Koormann, Bernhard Reiter, Dr. Jan-Oliver Wagner
-------------- next part --------------
20080621 + 20080622 Bernhard
Upgrading from server 2.1.0 to 2.2rc3 on a sarge machine.

Notes on 1st.README of Server sources/  for 2.2rc3:
( README.1st,v 1.81 2008/05/23 10:29:54 thomas )

* The following section does not seem to be uptodate:
	Upgrade from 2.2-beta3 to 2.2-rc1

	Updating the free/busy cache has to be triggered for all calendar
	folders of all accounts:
	- Users need to create or update an appointment in their folders.
	- Resources can be invited to a new appointment or send them an update
	  to an existing appointment.

at least if you are upgrading to 2.2rc3 from earlier versions
you would not need that method anymore.

* I think the section about generating your own 00Index files should
not be in between the general and the specific update instructions.

* bash  /media/cdrom/sources/install-kolab.sh -H -F -i /media/cdrom/sources
might be better, because without "bash" on some machines I get
a message:
	-su: /media/cdrom/sources/install-kolab.sh: /bin/sh: bad interpreter: Permission denied

* Somebody with a network connection would do requests that show
  that Kolab Server is building, see
  xsltproc2.html:3: validity error : Validation failed: no DTD found !
<html xmlns="http://www.w3.org/1999/xhtml"><head><meta http-equiv="Content-Type"
  make[2]: [xsltproc.html] Error 4 (ignored)
  I/O error : Attempt to load network entity http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd

* It is unclear which messages to search for in the build log.
  The list of installed or updated packages is missing, thus it is hard to
  find out if a compilation was successful or not. Maybe a hint would be cool
  saying: install-kolab.sh will stop if it encounters and error or
  search for "Error:" in the build log to see if everthing worked fine.
  (Or what ever is correct.)

* When doing step 8. merging the kolab.conf file, the new template has
	base_dn : @@@kolab_basedn@@@
	bind_dn : cn=manager,@@@kolab_basedn@@@
	but the original has an ",cn=internal" between "cn=manager"
	or "cn=nobody", and @@@kolab_basedn@@@

	The ",cn=internal" is necessary at least if in your old 
	.ldiff this is where it is. I am unsure about fresh bootstraps
    	without looking it up.

	Also there are no calender user lines in the template, so somebody
	merging might possibly forget them.

* templates/master.cf.template has tabs in there now, mixing tabs and spaces,
  compared to last time. Would be better to converts the tabs to spaces.

* Method: https://yourserver.example.com/freebusy/generatefb.php does not work
  for me (Konqueror, firefox from Sarge)
        I only get "Failed to authenticate! Please authenticate!"
	but no dialog, so probably the webserver does not request the

* the OpenPKG warning for some packages in the buildlog like:
| This OpenPKG package is of class JUNK.                                      |
| This means it is still in DEVELOPMENT state.                                |
| Hence it is still NOT ready even for general evaluation.                    |
| Do not use it at all, except in development environments!                   |
| It is definitely unstable and incompletely packaged.                        |
  is overdone as this is not true for many package as we did test them.
  So people will ignore this warning for good reasons most of the time
  and will also ignore it, if it was true. 
  Don't know what we could do about it, though.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: not available
URL: <http://lists.kolab.org/pipermail/devel/attachments/20080622/897b0716/attachment.sig>

More information about the devel mailing list