Update 2.1 auf 2.2

U Oe kb at oe-s.de
Di Okt 14 09:27:52 CEST 2008


Hallo Gunnar,

danke für deine Mühe, ich verwende aber tatsächlich Debian 4.0
Die "alte" Installation erfolge auf Debian 3.1, das System ist aber  
inzwischen Debian 4.0

Ich werde es zuerst mit dem neuen Installer versuchen, ansonsten muss  
ich wohl die Sourcen verwenden.
Da der Server virtualisiert läuft, habe ich das ganze schon an einem  
Klone versucht. Die Installation der Sourcen würde funktionieren  
(dauert aber sehr lange).

Vielen Dank
und Grüße
Werner




Quoting Gunnar Wrobel <wrobel at pardus.de>:

> Quoting Gunnar Wrobel <wrobel at pardus.de>:
>
>> Hallo Werner,
>>
>> Quoting U Oe <kb at oe-s.de>:
>>
>>> Danke für den TIP,
>>>
>>> das Löschen von
>>> (/kolab/bin/openpkg rpm -e openpkg-2.5.4-2.5.4)
>>> funktioniert aber leider nicht.
>>>
>>> Ich bekomme dann folgende Fehlermeldungen:
>>>        openpkg >= 2.5.0 is needed by (installed) libxml-2.6.22-2.5.0
>>>        openpkg >= 2.5.0 is needed by (installed) libxslt-1.1.15-2.5.1
>>>        openpkg >= 2.5.0 is needed by (installed) gmp-4.1.4-2.5.0
>>>        openpkg >= 2.5.0 is needed by (installed)
>>> spamassassin-3.1.0-2.5.1_kolab
>>>        openpkg >= 2.5.0 is needed by (installed) bc-1.06-2.5.0
>>>        openpkg >= 2.5.0 is needed by (installed) pkgconfig-0.19-2.5.0
>>>        openpkg >= 2.4.3 is needed by (installed)    
>>> clamav-0.90.2-20070413_kolab
>>>        openpkg >= 2.5.0 is needed by (installed) perl-kolab-5.8.7-20070420
>>>        openpkg >= 2.5.0 is needed by (installed) amavisd-2.3.3-2.5.0_kolab
>>>        openpkg >= 2.5.0 is needed by (installed) perl-ssl-5.8.7-2.5.0
>>>        openpkg >= 2.5.0 is needed by (installed) imap-2004g-2.5.0_kolab
>>>        openpkg >= 2.5.0 is needed by (installed) sasl-2.1.21-2.5.0
>>>        openpkg >= 2.5.0 is needed by (installed) postfix-2.2.5-2.5.0_kolab
>>>        openpkg >= 2.5.0 is needed by (installed) imapd-2.2.12-2.5.0_kolab2
>>>        openpkg >= 2.5.0 is needed by (installed) apache-1.3.33-2.5.6_kolab2
>>>        openpkg >= 2.5.0 is needed by (installed) php-4.4.0-2.5.2_kolab2
>>>        openpkg >= 2.5.0 is needed by (installed) curl-7.15.0-2.5.2
>>>
>>> das ist nur ein Ausschnitt.
>>> Somit hat mir das auch nicht weiter geholfen.
>>
>> Jo, in der Tat macht das dann wenig Sinn. Ich habe mir jetzt noch   
>> mal  den von Dir geschickten Output und den Code des Installers   
>> angesehen  und gehe davon aus, dass der Installer noch einen Bug   
>> hatte.
>>
>> Kannst Du bitte den aktualisierten Installer mit
>>
>>  wget    
>> http://kolab.org/cgi-bin/viewcvs-kolab.cgi/*checkout*/server/install-kolab.sh
>>
>> herunterladen und die Installation erneut starten? Funktioniert das  
>>   neue Skript?
>
> Korrektur: Der Fehler liegt nicht im Skript. Siehe   
> https://www.intevation.de/roundup/kolab/issue3138. Bitte einfach die  
>  Source-Pakete für das Upgrade verwenden, da die von Dir   
> heruntergeladenen Pakete nicht auf Dein System passen (Debian   
> 4.0/Debian 3.1).
>
> Gruß,
>
> Gunnar
>
>>
>> Gruß,
>>
>> Gunnar
>>
>>>
>>> Viele Grüße
>>> Werner
>>>
>>>
>>> Quoting Gunnar Wrobel <wrobel at pardus.de>:
>>>
>>>> Hallo Werner,
>>>>
>>>> Quoting U Oe <kb at oe-s.de>:
>>>>
>>>>> Hi Gunnar,
>>>>>
>>>>> danke für den Tip
>>>>> es zeigt bei mir
>>>>> "openpkg-2.5.4-2.5.4"
>>>>> an.
>>>>>
>>>>> Ist das die richtige Version?
>>>>
>>>> Die Version ist schon okay. Hast Du den vorigen Vorschlag mit dem
>>>> Entfernen des Paketes so abgewandelt, dass es auf die bei Dir
>>>> vorliegende Versionsnummer passt?
>>>>
>>>> Also:
>>>>
>>>> /kolab/bin/openpkg rpm -e openpkg-2.5.4-2.5.4
>>>>
>>>> Das müsste das Paket in Deinem System entfernen und danach klappt
>>>> das  Upgrade dann hoffentlich wie bei demjenigen, der diesen
>>>> Workaround  vorgeschlagen hat.
>>>>
>>>> Gruß,
>>>>
>>>> Gunnar
>>>>
>>>>
>>>>>
>>>>> Danke
>>>>> Werner
>>>>>
>>>>>
>>>>>
>>>>> Quoting Gunnar Wrobel <wrobel at pardus.de>:
>>>>>
>>>>>> Quoting U Oe <kb at oe-s.de>:
>>>>>>
>>>>>>>
>>>>>>> Danke Gunnar,
>>>>>>>
>>>>>>> das Problem wurde dort angesprochen mit folgendem Vorschlaf:
>>>>>>> -------------------------------------------------------------
>>>>>>> this did the trick:
>>>>>>>
>>>>>>> /kolab/bin/openpkg rpm -e openpkg-2.4.3-2.4.3
>>>>>>>
>>>>>>> can someone add this to the upgrade instructions?
>>>>>>>
>>>>>>> On 25 Sep, 2008, at 12:09 , Cristian Livadaru wrote:
>>>>>>> ------------------------------------------------------------
>>>>>>> Bei mir erscheint dann folgende Meldung:
>>>>>>>
>>>>>>> mail2:/# /kolab/bin/openpkg rpm -e openpkg-2.4.3-2.4.3
>>>>>>> error: package openpkg-2.4.3-2.4.3 is not installed
>>>>>>> mail2:/#
>>>>>>>
>>>>>>> das hilft leider auch nicht weiter.
>>>>>>>
>>>>>>> Hat noch jemand eine Idee?
>>>>>>
>>>>>> Was ergibt denn:
>>>>>>
>>>>>> /kolab/bin/openpkg rpm -q openpkg
>>>>>>
>>>>>> ?
>>>>>>
>>>>>> Gruß,
>>>>>>
>>>>>> Gunnar
>>>>>>
>>>>>>
>>>>>>> Danke
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> Quoting Gunnar Wrobel <wrobel at pardus.de>:
>>>>>>>
>>>>>>>> Quoting U Oe <kb at oe-s.de>:
>>>>>>>>
>>>>>>>>> Vielen Dank Jeromino,
>>>>>>>>>
>>>>>>>>> für die schnelle Antwort.
>>>>>>>>>
>>>>>>>>> Ich setzte aber wirklich Debian 4.0 ein (nicht Debian 3x).
>>>>>>>>> Ist es möglich, das diese Meldung von der alten Kolabinstallation
>>>>>>>>> kommt? Die erste Installation fand, falls ich mich recht  
>>>>>>>>> erinnere, mit
>>>>>>>>> den Debian 3.1 Paketen statt.
>>>>>>>>> Hindert das den Upgradeprozess?
>>>>>>>>>
>>>>>>>>> Kann ich die Versionsprüfung irgendwo deaktivieren, bzw ist das
>>>>>>>>> überhaut sinnvoll?
>>>>>>>>
>>>>>>>> Such mal auf der englischen Mailing-Liste. Ich meine da wurden
>>>>>>>> entsprechende Probleme in den letzten zwei Monaten mal diskutiert.
>>>>>>>>
>>>>>>>> Gruß,
>>>>>>>>
>>>>>>>> Gunnar
>>>>>>>>
>>>>>>>>>
>>>>>>>>> Danke und
>>>>>>>>> viele Grüße
>>>>>>>>>
>>>>>>>>> Werner
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> Quoting Jeronimo Wanhoff <wanhoff at lat-lon.de>:
>>>>>>>>>
>>>>>>>>>> Hallo Werner,
>>>>>>>>>>
>>>>>>>>>>> ich versuche ein Update vom Kolab 2.1 auf 2.2 durchzuführen.
>>>>>>>>>>> System Debian 4.0.
>>>>>>>>>> ...
>>>>>>>>>>> "/tmp/install-kolab.15671.27166.8009.7342" -p  
>>>>>>>>>>> "ix86-debian3.1-kolab"
>>>>>>>>>>
>>>>>>>>>> ein Schuss ins Blaue:
>>>>>>>>>> Vielleicht ein Versionskonflikt? Dein System ist Debian 4.0, in
>>>>>>>>>> der Meldung
>>>>>>>>>> steht ein debian3.1.
>>>>>>>>>>
>>>>>>>>>> Gruß,
>>>>>>>>>> 	Jeronimo
>>>>>>>>>>
>>>>>>>>>> --
>>>>>>>>>> Jeronimo Wanhoff
>>>>>>>>>>
>>>>>>>>>> l a t / l o n  GmbH
>>>>>>>>>> Aennchenstrasse 19               53177 Bonn, Germany
>>>>>>>>>> phone ++49 +228 18496-0          fax ++49 +228 18496-29
>>>>>>>>>> http://www.lat-lon.de            http://www.deegree.org
>>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> _______________________________________________
>>>>>>>>> Kolab-users-de mailing list
>>>>>>>>> Kolab-users-de at kolab.org
>>>>>>>>> http://lists.wald.intevation.org/mailman/listinfo/kolab-users-de
>>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>> --
>>>>>>>> ____ http://www.pardus.de _________________ http://gunnarwrobel.de _
>>>>>>>>
>>>>>>>> E-mail : p at rdus.de                                 Dr. Gunnar Wrobel
>>>>>>>> Tel.   : +49 700 6245 0000                         Bundesstrasse 29
>>>>>>>> Fax    : +49 721 1513 52322                        D-20146 Hamburg
>>>>>>>> --------------------------------------------------------------------
>>>>>>>> >> Mail at ease - Rent a kolab groupware server at p at rdus <<
>>>>>>>> --------------------------------------------------------------------
>>>>>>>>
>>>>>>>>
>>>>>>>> ----------------------------------------------------------------
>>>>>>>> This message was sent using IMP, the Internet Messaging Program.
>>>>>>>>
>>>>>>>> _______________________________________________
>>>>>>>> Kolab-users-de mailing list
>>>>>>>> Kolab-users-de at kolab.org
>>>>>>>> http://lists.wald.intevation.org/mailman/listinfo/kolab-users-de
>>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> _______________________________________________
>>>>>>>