[Kolab-devel] Kolab Server 2.2.0 Final Release update error (2.1 -> 2.2)

Thomas Arendsen Hein thomas at intevation.de
Sun Jul 13 09:44:35 CEST 2008

* Jens Mohr <jens.mohr at congster.de> [20080712 23:06]:
> on update from release 2.1 to 2.2 i get this error:
> Executing(%install): env -i /kolab/lib/openpkg/bash --norc --noprofile --posix -e /kolab/RPM/TMP/rpm-tmp.47755
> + cd /kolab/RPM/TMP
> + cd perl-mail-5.10.0
> + rm -rf /kolab/RPM/TMP/perl-mail-5.10.0-root
> + /kolab/bin/perl-openpkg prepare
> IO object version 1.23_01 does not match bootstrap parameter 1.23 at /kolab/lib/perl/5.10.0/i686-linux/DynaLoader.pm line 226.
> Compilation failed in require at /kolab/bin/perl-openpkg line 29.
> BEGIN failed--compilation aborted at /kolab/bin/perl-openpkg line 29.
> error: Bad exit status from /kolab/RPM/TMP/rpm-tmp.47755 (%install)
> my update procedure is:
> # kolab/bin/openpkg rc all stop
> # umask 077
> # /kolab/sbin/slapcat > ~/kolab-2.1.ldif
> # /kolab/bin/openpkg rpm -e --nodeps kolabd kolab-webadmin kolab-horde-fbview kolab-horde-framework kolab-resource-handlers getopt patch proftpd sharutils
> # /kolab/bin/openpkg rpm --rebuild ./openpkg-20071227-20071227.src.rpm
> # /kolab/bin/openpkg rpm -Uvh /kolab/RPM/PKG/openpkg-20071227-20071227.ix86-fedora6-kolab.rpm
> # /kolab/bin/openpkg rpm --rebuild ./openpkg-tools-1.4.6-20071231.src.rpm
> # /kolab/bin/openpkg rpm -Uvh /kolab/RPM/PKG/openpkg-tools-1.4.6-20071231.ix86-fedora6-kolab.rpm
> # sh install-kolab.sh 2>&1 | tee /root/kolab-update.log &
> my system is:
> FC6 (32bit/Athlon)
> gcc-Version 3.4.6 20060404 (Red Hat 3.4.6-4)

Sounds much like
which we experienced on one machine with server 2.2-rc1, too.

What worked for us:

1. WARNING: make a backup, I needed it!
2. remove all packages which install files below /kolab/lib/perl/
   (with -e --nodeps), this includes the imapd package, but removing
   this will remove mailboxes.db and annotations.db, too, so either
   use your backup or try if you can convince rpm to not execute the
   removal script (with --noscripts or something like that, I
   haven't tried).
3. make sure /kolab/lib/perl/ is empty, either by looking at 2.
   again or removing the remaining files
4. Recompile the packages you removed above again, for this you can
   put all source rpms and all your non-perl binaries (from
   /kolab/RPM/PKG) in a directory writable by the kolab user, run
   'install-kolab.sh -X' in it to generate a new 00INDEX.rdf
   and use this for the new try. This is described in 1st.README, too.


thomas at intevation.de - http://intevation.de/~thomas/ - OpenPGP key: 0x5816791A
Intevation GmbH, Osnabrueck - Register: Amtsgericht Osnabrueck, HR B 18998
Geschaeftsfuehrer: Frank Koormann, Bernhard Reiter, Dr. Jan-Oliver Wagner

More information about the devel mailing list